Revisions for WorkflowStepSequence

RevisionTermsStatus
Saved 06/17/2019 - 21:20 by wendy

TC-143 added note to explanatory material to explain the use of both "executes" and orderedSteps resulting from pattern change.

Proposal current revision (published)
Saved 07/20/2018 - 20:19 by wendy

TC-142 documentation tweek

Proposal archived
Saved 05/24/2018 - 19:27 by wendy

TC-130 NOTE no longer realizes a SimpleCollection. Changed extension base to WorkflowControlStep and property contains to orderedStep; removed isOrdered, type, realization, definingConcept

Proposal archived
Saved 04/11/2018 - 22:49 by wendy

realizes ProcessSequence TC-100

Proposal archived
Saved 03/22/2018 - 21:44 by wendy

TC-74

Proposal archived
Saved 01/30/2018 - 06:58 by jay

Updates doc

Proposal archived
Saved 01/22/2018 - 18:36 by wendy

returned it to a simple collection

Proposal archived
Saved 01/20/2018 - 08:26 by jay

Updates doc

Proposal archived
Saved 01/19/2018 - 23:31 by larry

added isOrdered - required by realizes SimpleCollection

Proposal archived
Saved 01/19/2018 - 23:17 by jay

updates doc

Proposal archived
Saved 01/16/2018 - 14:05 by jay

tweak doc

Proposal archived
Saved 01/16/2018 - 14:02 by jay

updates doc

Proposal archived
Saved 01/13/2018 - 09:22 by jay

corrects type in class name

Proposal archived
Saved 11/15/2017 - 19:37 by wendy

changed to realize simple collection per DMT-159

Proposal archived
Saved 09/27/2017 - 19:31 by wendy

updated isStructuredBy

Proposal archived
Saved 09/26/2017 - 15:11 by wendy

added name and purpose after changing extension base to annotated identifiable.

Proposal archived
Saved 09/26/2017 - 15:03 by wendy

renamed class

Proposal archived
Saved 09/25/2017 - 22:59 by wendy

removed substep as this is handled by relation structure, moved workflowstepindicator to property as it is a complex data type

Proposal archived
Saved 09/20/2017 - 11:42 by jay

documentation

Proposal archived
Saved 09/18/2017 - 18:37 by jay

spelling

Proposal archived
Saved 09/18/2017 - 18:17 by jay

changed relationship contains to containsSubStep

Proposal archived
Saved 01/06/2017 - 21:49 by wendy

added contains WorkflowStep

Proposal archived
Saved 01/06/2017 - 21:47 by wendy

changed name to WorkflowStepCollection; renamed type of Sequence to typeOfWorkflowStepCollection; removed constructSequence and this no longer makes sense with specific sequencing. Alternate sequences such as randomization can be defined using conditional control constructs.

Proposal archived
Saved 10/03/2016 - 16:40 by wendy

removed SequenceOrder

Proposal archived
Saved 09/27/2016 - 19:50 by wendy

added the sequence order to the workflow sequence. If this should be outside of the workflow sequence it needs a means of being bound into the workflow sequence

Proposal archived
Saved 09/13/2016 - 15:27 by flavio.rizzolo

Updated realization.

Proposal archived
Saved 08/24/2016 - 15:27 by flavio.rizzolo

Revised definition.

Proposal archived
Saved 08/23/2016 - 17:04 by flavio.rizzolo

Renamed from Process Sequence.

Proposal archived
Saved 08/03/2016 - 19:20 by wendy

added type property

Proposal archived
Saved 05/11/2016 - 16:50 by wendy

changed to more specific name of ProcessSequence

Proposal archived
Saved 04/08/2016 - 22:52 by flavio.rizzolo

Added Sequence Order.

Proposal archived
Saved 10/18/2015 - 10:14 by flavio.rizzolo
Proposal archived
Saved 05/30/2014 - 17:21 by brigitte

Should be revised again to include a data type for TypeOfSequence Revised for consistency at Toronto sprint

Proposal archived
Saved 05/29/2014 - 16:37 by guillaume
Proposal archived
Saved 05/28/2014 - 22:20 by marcel
Proposal archived
Saved 05/23/2014 - 14:08 by ddi4
Proposal archived